XE 의 확장변수는 참 유용하게 사용되는 입력항목이다.

게시판이나 기타 여러 모듈에서 필요한 정보를 추가적으로 입력할때 사용하는데, 

개인적인 필요에 의해 HTML5 의 필수항목(required) 알림이나, 입력항목에 설명이 출력되는 placeholder 의 기능을 적용한 소스파일을 첨부한다.

간혹 XE 전체 업데이트할때 개인적으로 수정한 파일이 XE 원본 소스로 바뀌게 되면,

다시 재수정해야 하는 불편함이 있어서 이곳에 공유해서 함께 나누면 더 좋고 편리할 것 같다는 내생각 ^^.


다음은 수정한 예제...

./classes/extravar/Extravar.class.php 에서 353-459번째 라인에서 필요한 부분을 수정하면 된다.

// General text

default :

$buff[] =' <input type="text" name="' . $column_name . '" value="' . ($value ? $value : $default) . '"' . ($required=='Y' ? 'required ' : '') . ($desc!='' ? ' placeholder="'. $desc .'"' : '') . ' class="text" />';


첨부된 파일은 XE 1.7.10 상위버전에 사용가능합니다.